Last Scenario on Windows 7
  • I have Windows 7 on my computer currently, and every time I try to run Last Scenario, none of the text is visible.  Everthing else in the game seems fine.  Has anyone successfully gotten this game to run on Windows 7? 

    I read somewhere that the msgothic.ttc file needs to be deleted when using Windows Vista, but am not sure if that applies to Windows 7.  Let me know what you think
  • Could a vital font be missing?
  • Here's what I would suggest:

    Try playing Exit Fate and find out if the same problem occurs.

    http://www.scfworks.com/ef.php

    There is a section called Font Issues which you can follow. It might solve the issue.

    If Last Scenario still doesn't work, send an email with your configuration to SCF at:

    http://www.scfworks.com/about.php

    Let us know if you've found a solution as well. :)
  • [quote="Madgamer"]
    I read somewhere that the msgothic.ttc file needs to be deleted when using Windows Vista, but am not sure if that applies to Windows 7.  Let me know what you think


    As Windows 7 is pretty much a bug-fixed Vista, then that should apply too I'd guess.
  • I found the answer on the Last Scenario web page, but had to research on google to understand what the creators meant lol. 

    This is what is shown on the Last Scenario page:
    •Go to Configuration Screen, then to Regional Settings
    •Go to the Administrative tab and set language for non-unicode programs to Japanese
    •Reboot your PC. At this point, Exit Fate should be unable to find MS Gothic and revert to Courier New.
    •Go back to Regional Settings and set the language for non-unicode programs to its original language.
    •Reboot your PC again. Now, Exit Fate should properly use MS Gothic.


    At first, I said to myself, "What 'configuration screen' ?".  What they mean is this:
    *Go to your control panel and select the option "Clock, Language, and Region"
    *When this screen opens, select Region and Language
    *NOW you can select the Administrative tab and you'll find the section labeled Language for non-Unicode programs
    *Select Japanese as the language for non-Unicode programs, and you will be prompted to reboot your pc
    *When rebooted, load up Last Scenario and it will be unable to find MS Gothic and will revert to Courier New. You are now able to see text when the game loads
    *You can now set the language for non-Unicode programs back to the original language (and can play Last Scenario to your heart's content!!!


    Thanks for the Link, Tim.  That solved the issue for me.  Hopefully this post will help someone else in my situation

    ~Larry
  • *WARNING*

    I tried to follow the instructions from the Last Scenario site that reads the following but it's wrong:

    "•Go back to Regional Settings and set the language for non-unicode programs to its original language.
    •Reboot your PC again. Now, Last Scenario should properly use MS Gothic."

    This did NOT work for me, and I still had no text when I rebooted with the original language.  So I'm just going to leave the language for non-Unicode programs as Japanese.  I don't think I'll have a need to ever change this.  If anyone has a better fix for this let me know, but this seems to work fine.  Also, if you have any questions feel free to ask!

    ~Larry
  • Sorry to hear that it didn't work. Have you tried emailing the author? He might have a solution or two that you could try.

    I've talked to him some time ago, and he's working on a new game as well (but most likely using the same engine). If you can't get his games to work, then you won't be able to play his new release when it comes out in a few years' time.
  • Hey Tim, sorry for the confusion.  You see, the game DOES work when I leave the non-Unicode langauge as Japanese.  I'm going to leave it that way and just play the game.  I seriously doubt that this change will cause a problem for me in other applications.  So I'm happy in the end!

    I have Exit Fate and Last Scenario and am looking forward to playing Last Scenario right after I beat Cave Story, hehe. 

    ~Larry
  • Yep, that's what I did as well. :) I'd recommend playing Exit Fate first (since the latter isn't a sequel to the former, so you don't have to play Last Scenario to know any backstory).

    Another reason is that EF plays a lot better than LS.
  • That's an interesting observation, Tim.  I guess it makes sense for Exit Fate to be a little smoother since it was made after LS.  I have been wanting to play LS for a while now, so I think i'll give that a go first.  You see, I have decided to stay completely freeware when it comes to my gaming experiences, so when solid titles like LS and EF come out, I'll be sure to play 'em! 

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

In this Discussion